Experts agree that Every building needs a Fire Safety Plan

Is your plan
stored on our server?
Login below.

System Requirements

In order to use the eZfireplan service you will need the following.

- A current, valid e-mail address.
- Program to view pdf documents .
- Macromedia's Flash Player .
- A minimum of Internet Explorer 6 or Firefox 3.